---
title: Supported LDAP extended operations
description: LDAP extended operations define additional operations for services not already available in the protocol.
component: pingds
version: 7.4
page_id: pingds:ldap-reference:extended-ops
canonical_url: https://docs.pingidentity.com/pingds/8.1/ldap-reference/extended-ops.html
llms_txt: https://docs.pingidentity.com/pingds/llms.txt
docs_for_agents: https://developer.pingidentity.com/build-with-ai/docs-for-agents.md
revdate: 2023-08-10T15:45:40Z
keywords: ["Features", "LDAP", "Standards"]
superseded_by: https://docs.pingidentity.com/pingds/8.1/ldap-reference/extended-ops.html
---

# Supported LDAP extended operations

LDAP extended operations define additional operations for services not already available in the protocol.

DS software supports the following LDAP extended operations:

* Cancel Extended Request

  Object Identifier: 1.3.6.1.1.8

  RFC: [RFC 3909: Lightweight Directory Access Protocol (LDAP) Cancel Operation](https://www.rfc-editor.org/info/rfc3909)

- Get Connection ID Extended Request

  Object Identifier: 1.3.6.1.4.1.26027.1.6.2

  DS extended operation to return the connection ID of the associated client connection. This extended operation is intended for DS internal use.

* Password Modify Extended Request

  Object Identifier: 1.3.6.1.4.1.4203.1.11.1

  RFC: [RFC 3062: LDAP Password Modify Extended Operation](https://www.rfc-editor.org/info/rfc3062)

- Password Policy State Extended Operation

  Object Identifier: 1.3.6.1.4.1.26027.1.6.1

  DS extended operation to query and update password policy state for a given user entry.

* Start Transport Layer Security Extended Request

  Object Identifier: 1.3.6.1.4.1.1466.20037

  RFC: [RFC 4511: Lightweight Directory Access Protocol (LDAP): The Protocol](https://www.rfc-editor.org/info/rfc4511)

- Who am I? Extended Request

  Object Identifier: 1.3.6.1.4.1.4203.1.11.3

  RFC: [RFC 4532: Lightweight Directory Access Protocol (LDAP) "Who am I?" Operation](https://www.rfc-editor.org/info/rfc4532)
