Upgrading the Trust Framework and policies - PingAuthorize - 9.3

PingAuthorize 9.3

bundle
pingauthorize-93
ft:publication_title
PingAuthorize 9.3
Product_Version_ce
PingAuthorize 9.3 (Latest)
category
ContentType
Product
Productdocumentation
paz-93
pingauthorize
ContentType_ce
Product documentation

PingAuthorize ships with a default Trust Framework and policy snapshot that policy writers should use as a starting point when developing their policies. Occasionally, a server upgrade results in changes to the default Trust Framework and policies, and policy writers must upgrade any policies based on defaultPolicies.SNAPSHOT.

  1. Sign on to the Policy Editor and choose any branch to go to the main landing page.
  2. Select Branch Manager from the navigation bar on the left, and open the Merge Snapshot tab.
  3. Click the file selection option, and go to the resource/policies/upgrade-snapshots folder of the new Policy Editor deployment.
  4. Select the correct SNAPSHOT file based on the version you are upgrading from and the version to which you are upgrading.
    Important: If you are upgrading from 7.3.0.x, use the 7.3.0.x-to-8.0.0.0-SNAPSHOT and merge that (per the next step) before you select and merge 8.0.0.0-to-8.1.0.0.SNAPSHOT.
    When upgrading from version 8.0.0.0 to version 8.1.0.0, use resource/policies/upgrade-snapshots/8.0.0.0-to-8.1.0.0.SNAPSHOT.
  5. Merge the partial snapshot.
    Note:

    Merge conflicts might occur where objects have been updated. If you have not modified the objects in conflict, you can safely select Keep Snapshots.

  6. Return to your PingAuthorize Server installation.
  7. Run the following dsconfig command to configure PingAuthorize Server to use the latest Trust Framework version:
    dsconfig set-policy-decision-service-prop \
      --set trust-framework-version:v2